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Text, Guides and Effects

Using Adobe Photoshop
9 – Text, Guides and Effects
In the exercises that follow, we will use a combination of type layer editing, guidelines, effects
and other techniques to create a basic graphical layout for a website. Photoshop is considered by
many web designers to be an essential tool and is well suited for the work, though these
techniques can all be used for other work as well.

Exercise 1 –

Creating the Canvas

1) Make sure Photoshop is open.
2) Create a new image [Ctrl] [N].
3) From the list of presets, select 800 x 600. People browsing the web have their screen
resolution on a variety of settings, but 800 x 600 is the most common setting used so many
web designers make this the standard size for their designs.

4) Enter Main Page Template as the Name of the new document.
5) Make sure the other settings are as shown below and click OK.
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Planning
A good web designer knows the importance of planning. Often this will take the form of
storyboards, notes and draft designs of page layouts on paper. For the purposes of these
exercises, we will assume that there has been plenty of planning since it’s normally not a good
idea to try and make it up as you go along.
Our web page will be designed so that there is a bar down the side with the main navigation
links as well as a bar along the top with the main heading. The illustration below shows a
sample draft design for the page.
LOGO

Main Heading

Home
About Us
Products
Orders
Contact Us
Links

Main page content
Image

Navigation links 180
pixels wide and 25
pixels high

When you are setting up an image in Photoshop, you can use ruler guides as a convenient way
of helping you plan the layout and make sure things are evenly lined up.

Exercise 2 –

Adding Ruler Guides

1) Show rulers on your image by selecting Rulers from the View menu or
pressing [Ctrl] [R].
2) If the rulers are set to a measurement other than pixels (such as
centimetres) you can change it by right clicking on a ruler. Right click on a
ruler and make sure Pixels is set for the measurements.
3) Create a vertical ruler guide by moving your mouse over the vertical ruler
and then dragging on to the image. Keep on dragging until the guide lines
up with the 180 pixel mark on the top ruler. This will mark the width of the page navigation.

Tip

You can see if you’re in the right spot by making sure the Info palette
is showing. This will show you exactly how far across you are
dragging the guide.

Note

If you want to move a ruler guide that you have already placed, hold
down [Ctrl] as you drag it.
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4) Create a horizontal ruler guide by dragging from the
horizontal ruler. Line it up with the 50 pixel mark on
the vertical ruler. This will mark the height of the
page heading.
5) Create additional horizontal guidelines at 25 pixel intervals until you get down to the 225
pixel mark. Each of these will mark the borders between each navigation button.
6) Create a final guideline to mark the bottom of the navigation bar. This will be at the 550
pixel mark. The final array of guides should look like the example below.

7) Save the image as a Photoshop (PSD) file. The document name of Main Page Template.psd
should be used as the filename.
You can hide and unhide guides whenever you
need. One way is to turn the option on and off
from the View menu. A quicker way is to use
the keyboard shortcut shown in the menu.
8) Press [Ctrl] [;] (semicolon) to hide the guides.
9) Press [Ctrl] [;] again to unhide them.
Tip

If you want to create guides that divide the image in to even
sections, it might help to use the New Guide option from the
View menu. This allows you to place a guide’s distance as a
percentage. So for example, if you want a guide to be exactly
quarter of the way down the image, choose new guide and enter
25% as the amount.
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Using Vector Shape Tools
Although Photoshop is primarily a tool for editing raster graphics while
other tools such as Illustrator are aimed more at editing vector graphics,
Photoshop does have some basic vector tools that can be used for editing
vector shapes. These can be used to quickly create a variety of shapes and
selections in a document.
A vector shape can be created using the Pen tools
, which allow you to create
freehand vector shapes. If you want more even shapes, you can select from the shape tools.
These will create shapes such as rectangles and circles which can be modified afterwards. This
is the method we will use.

Exercise 3 –

Creating Shapes with Shape Tools

1) We want the bottom of our navigation bar to have a rounded
corner so we will start by selecting the Rounded Rectangle tool
[U] or [Shift] [U] to cycle between shape tools
.
2) The Radius option determines the size of the curve on the corners. Set the Radius option to
25 px.

1) Resize the border of the image window to make sure you can see plenty of blank space
around the drawing canvas.

2) Select a dark blue foreground colour before drawing.
3) Draw a rounded rectangle that starts well outside the edge of the
drawing canvas and extends to the bottom right corner of the
navigation bar as marked by our guides. As you are drawing,
your mouse should lock on the any guides it comes close to. If it
doesn’t, you will need to enable the Snap To Guides option
from the View menu. If it is positioned correctly then only the
bottom right corner should have any of the curve visible.
4) If it’s not in quite the right spot as shown to the right, undo and
try again.
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5) Select the Rectangle Tool .
6) Draw a rectangle across the top of the image that stops just
short of the right edge and overlaps the first shape. The
bottom should come down to the first horizontal guide.

Now we’ll edit the shape that has just been added.
. This is used to edit the
7) Select the Direct Selection Tool [A]
points in a vector shape to change its edges.
8) Click on the edge of the shape you have just drawn. Small squares on each corner will mark
the anchor points. Anchor points can be added or removed. We’ll be doing both.
9) Move your mouse to the right edge of the shape and position it about 20 pixels from the
bottom corner (remember you can use the info palette to guide you – it should be about 30
pixels from the top of the image).
10) Right click on the edge and select Add Anchor Point.
11) Create another anchor point positioned 20 pixels to the left of
that same corner.
12) Right click on the corner and select Delete Anchor Point. You
should now have two anchor points positioned a short distance
from the corner.
The corner will still look straight but that is because each anchor
point has direction points which determine the direction the line
takes from that point. The longer a direction point, the longer a line will
go before curving towards the next point.
13) Position your mouse over the direction point for the first anchor
point you added.
14) Drag it cack towards the anchor point to shorten it. A shorter
direction point will mean a tighter curve.

Æ
15) Do the same to the direction point for the other anchor point. Take care to keep the direction
point straight, otherwise the curve may follow an unusual angle.
The result should be a smooth curve on the corner of the shape as shown both with and without
guides in the example below.
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Now we’ll create a different kind of curve. Currently there is a 90% angle where the two curves
meet. We want to create a smooth inner curve.
16) Start by dragging the two left anchor points so they line up with the vertical ruler guide.

Æ
17) Create a new anchor point about 20 pixels to the right of the corner.

Æ
18) Drag the corner anchor point downward until it meets the next ruler guide.

19) Adjust the anchor points and direction points until you get a nix even curve shape. You can
temporarily hide all visual aids with [Ctrl] [H] to check it.

Æ
20) In the layers palette, you should see a Shape 1 layer and a Shape 2
layer. The one currently selected will be highlighted in a darker
colour. Hold down [Ctrl] and click on the other layer until both are
selected.
21) From the Layer menu select Merge Layers or [Ctrl] [E] to combine both shapes.
You should now have the general shape needed for our site design.
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Adding Some Filter Effects

1) Save your image and make sure the Shape layer is still selected (you might want to rename
the layer to something more suitable).
2) From the Filter menu select Noise and then Add Noise.

3) Choose an Amount of about 20% and click OK.
4) From the Filter menu select Blur and then Gaussian Blur.

5) Choose a Blur amount of about 1 to 1.5 pixels and click OK. A textured pattern in the shape
should be the result.
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Adding Some Layer Effects

1) With the Shape layer still selected click the Effects icon
at the bottom of the Layers
Palette and select Bevel and Emboss.
2) Set the Bevel Structure options so they are similar to the options shown below.

3) From the list of Styles to the left, select Satin.
4) Click on Satin to show the options for the Satin style.
5) Adjust the Satin Opacity to around 25% and click OK.
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Type Layers
When want to add text to a Photoshop image, it is done using a Type Layer. In older versions of
Photoshop (version 5 and earlier), any text added to an image created rasterised layers with text
that couldn’t be edited. Version 6 added Type layers where you could edit the text after a layer
had been created and more recent versions have added even more versatile options for type.
You can create three sorts of Type Layers in an image and these are described below.
Point Type

A Point Type layer is created when you select the type tool and simply click on an image. This
will create a single line of text that expands or shrinks as you edit it. It is useful for adding a few
words to your image and is what we will use for these exercises.

Paragraph Type

If you use the Type tool to drag a rectangular area on the image, then a Type layer will be
created with that will extend as far as you dragged. The text will wrap within that area.

Type On A Path

Type on a path occurs when you click the Type tool on a vector path or on the edge of a vector
shape. Type created in this way will follow the shape of the path.

Æ

Note

You can convert a type layer between Point and Paragraph text by selecting the Layer menu,
selecting Type and then choosing the option to convert to the other type of layer.
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Adding a Heading

1) Click on the Type [ T ] tool
. You can format type after you have already typed it in the
image but you can also set your type options before you begin typing. When you have the
type tool selected or you are editing type, the type options will appear at the top in the
options palette.
2) Set the type options as shown below.

Font Arial, Bold, 24pt font size and centre aligned
3) Select White as your foreground colour. Any text you enter will use the foreground colour.
You can always change the colour of selected text when you are editing it, but it’s often
easier to get the colour before you enter the text.
4) Drag a rectangle shape that covers the top area of our shape as shown below. By dragging
we have created Paragraph Type.

5) We want a bit of space between the text and the top of the image. Move your mouse to the
selection handle in the middle of the top border. Drag it down slightly as shown below.

6) Type ACME Website in the text box.
When you are done don’t press [Enter] as this will only add another line to your text. To commit
changes to a type layer (in other words, finish editing the text), you can do one of the following.
•
•
•
•

Click the Commit button on the options palette or the Cancel button
Press [Ctrl] [Enter] to commit the changes or press [Esc] to cancel.
Press the [Enter] key on the numeric keypad.
Click on another tool or select a menu option.

to abandon changes

7) Use one of the methods just described to commit the changes to the Type Layer.
8) Click on the Effects icon
in the Layers Palette and select Bevel and Emboss.
9) Make sure Inner Bevel is selected. Select Down for the Direction and 2px for the Size.

You should now have a heading as shown below.
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Adding the text for the links

For the text links on the side we’ll create some Point text layers. Before we do, we’ll create a
layer group to organise them in. This will keep the layers palette a little more.
1)
2)
3)
4)

On the Layers Palette, click the Create a new Group icon at the bottom .
Double click the group name and rename it Links.
Select the Type Tool [T].
Set the type options to Comic Sans MS, Bold, 14pt left aligned, with the foreground colour
being set to yellow (or another light colour of your choosing).

5) Click between the second and third horizontal rule, to the left of the navigation bar area.

6) Type the word Home and then press [Ctrl] [Enter] to commit the type change. If your Links
Layer group was still selected, the new type layer will be added as part of the group. This is
indicated by the layer name being indented.
7) Add additional type layers so that they appear as below. For the time being don’t worry
about getting them lined up, but try to position the top and bottom one so that they are more
or less halfway between horizontal guides. Remember that is you want to move a layer with
the move tool [V], you will need to select the layer in the Layers Palette first.

8) In the Layers Palette, click on the first of the link layers and then hold [Shift] while clicking
on the last link layer. Each of the layers should now be linked together.
Note

In older versions of Photoshop (prior to Photoshop CS2), you
select layers by clicking on the blank box next to the hide layer
icon. A small chain icon will appear in the box to indicate the layer is linked.

9) Select the Move Tool [V]

.

When the move tool is selected, a number of alignment options will appear in the Options
Palette along the top. Note that these same options can also be found under the Layer menu

© Steve O’Neil 2006

Page 11 of 18

http://www.oneil.com.au/pc/

Using Adobe Photoshop

Text, Guides and Effects

10) Click on the Align Left Edges icon so that all of the links will have their left edges lined up.
11) Click the Distribute Vertical Centres
icon so that each of the Link layers will have their
centres evenly spaced between the top and bottom one.
Now that things are lined up, we’ll add some layer effects.
1) Select any one of the link layers and click the Effects icon at the bottom of the Layers Palette.
2) Add some layer effects of your choosing. In the example below, a raised inner bevel with a
satin overlay and a faint drop shadow were used.
3) Right click on the layer you applied the effects to and select
Copy Layer Style.
4) Select the other link layers.
5) Right click on one of the selected layers and choose Paste Layer
Style.

Exercise 8 –

Creating a Logo

1) Select the Ellipse Tool .
2) Select yellow as your foreground colour.
3) Draw an Oval shape in the top left corner of the page as shown
below.

4) Your new shape layer has probably been added to the Links layer group. Drag it up the list of
layers in the Layers Palette until it is above the Links layer group.

5) Rename the new layers as Logo Back.
6) Apply some layer effects to give the oval a rounded 3d look as shown below. In this
example it was done using the settings shown the next page.
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7) Select the Type Tool.
8) Select red as your foreground colour.
9) From the Options Palette, select Arial Black with 24pt font size.
10) Click on your document and enter the text ACME.
11) Hold down [Ctrl] to temporarily enable your Move tool and position the txt layer over the
yellow oval as shown.

12) Press [Ctrl] [Enter] to commit the changes to the type layer if you haven’t already done so.
13) Apply a Bevel and Emboss to the new layer with the following settings.

14) In the Layers Palette, change the blending mode to Multiply.
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Using Slices
We’ve got the design for your web page now. We aren’t just going to dump one big image in to
the page though. It will need to be split up and saved as different images to be placed in to the
web page. An easy way to do this is to use Photoshop’s Slices feature. Slices allow you to divide
the image up in to different sections. When you use Save for Web, each section (slice) can be
saved with its own filename and save settings.

Exercise 9 –

Slicing it Up

1) Create a new Vertical ruler guide approximately 200 pixels from the left of the image.

2) Select the Slice Tool [K] from the Tool Palette.
3) Drag a rectangle shaped area around your web design’s logo as shown below. Use the ruler
guides to help position the slice. It should extend as far as the guide you just added.

Normally, slices are not visible (they can be turned on from the View menu) but now that you
have created a slice, it has become visible and the remainder of the image has been divided in to
two auto slices.
4) Create another slice to cover the blank area under the logo and then create a slice for each of
the navigation buttons. Create a slice for the blank bottom section of the navigation bar.
Finally, create a slice for the heading. Remember to use the ruler guides. Once each of the
slices have been created, your image layout should look like the example below.

© Steve O’Neil 2006

Page 14 of 18

http://www.oneil.com.au/pc/

Using Adobe Photoshop

Text, Guides and Effects

The remainder of the image will be divided in to a small auto slice below the navigation bar and
another large one to the right of the navigation bar. We won’t use the auto slices since the
bottom one will be blank and the other one will be taken up with the main area of our website.
We’ll adjust some setting for our slices.
5) Select the Slice Select Tool.
6) Double click on the top left slice with the logo. The slice
options will appear.

7) Enter main_logo as the name. Make sure you use an underscore instead of a space since it is
best to avoid spaces in image names for websites.
Note

Image Ready and Photoshop allow you to export images complete with HTML code that can be
placed directly in to a web page. The other options are used for this purpose. If you create your
web pages using an application such as Dreamweaver, you might be better off exporting the
images alone and then using your regular web page editor to create the HTML code.

8) Click OK to confirm the slice settings change.
9) Rename the other slices as shown below.
main_logo

main_heading

main_top
main_home
main_about
main_products
main_orders
main_contact
main_links
main_bottom

We don’t want the remaining slices to be exported as images.
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10) With the Slice Select Tool still active, double click on the bottom auto slice.
11) Change Slice Type to No Image.

12) Repeat this to change the other auto slice to no image.
Now everything is ready for us to export the images.
13) From the File menu select Save for Web [Alt] [Shift] [Ctrl] [S].
14) Select the fist slice from the image with the Slice Select Tool.
If you have the 2Up tab
selected like in the example below, make sure you click the slice in the preview on the right.

15) Adjust the options on the right to optimise that section of the image. Watch the preview as
well as the file size estimate below it and use your own judgement to find a good balance
between file size and quality.
16) Adjust the optimisation settings for each of the other slices (except the no image slices
which you shouldn’t be able to select anyway).
17) Click Save.
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18) Browse for a suitable location to save to.
19) Change Save as type to Images Only. Ignore the filename. Instead of saving one file, Save
for Web will save a separate file for each of your slices, using the names of the slices as file
names.
20) Click Save. Check in the location you saved them to and there should now be an image for
each of your slices.

21) Each of these images could now be placed in to a web page. Save and close your image.
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Shortcuts Learned
[Ctrl] [R]
[Ctrl] [;]
[U]
[A]
[Ctrl] [H]
[Ctrl] [E]
[T]
[K]
[Alt] [Shift] [Ctrl] [S]
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Show / hide rulers
Show / hide ruler guides
Select s shape tool ([Shift] [U] to cycle between the shape tools)
Direct selection tool
Show / Hide all visual guides such as ruler guides, slices and selections
Merge selected layers
Type tool
Slice tool ([Shift] [K] to swap with Slice Select Tool)
Save for Web
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