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Using Adobe Photoshop 

4 ï Colours & Saving 
Colour is important in most art forms. For example, a painter needs to know 

how to select and mix colours to produce the right tones in a picture. A 

Photographer needs to understand how different lenses, filters and film types can 

affect the colours in the final print. Likewise, in Photoshop the quality of your work will 

often depend on how well you can work with colour. 

 
 

1 -  Image Modes 

As discussed in previous sections, raster images are made of pixels. Each pixel can be a 

different colour, though the range of colours for each pixel depends on the imageôs colour mode. 

When you create a new image in Photoshop, one of the options you can choose is the colour 

mode of the image. You can also convert existing images to different colour modes, though 

image quality often suffers when converting from one mode to another. Some of the colour 

modes supported by Photoshop are described below. 

 

Colour modes 
available for 

new images. 
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RGB Mode 

RGB (Red Green Blue) images are made up of three channels. One channel is for the red tones in 

the image, one for the green tones and one for the blue. Each of these channels combines, to 

create the colours in the image. This is similar to the way a TV screen uses red, green and blue 

dots to make a picture. E.g. 

 

 
The red channel shows the 
red tones in the image 

 
The green channel shows 
the green tones in the image 

 
The blue channel shows the 
blue tones in the image 

 
All three channels combine 
to create a colour image. 

 

Some image file formats, such as JPEG can only be saved in RGB mode. RGB mode is best 

suited for use in images that will be displayed on a screen, since your monitorôs picture is made 

up of a combination of red, green and blue light. Each channel is represented by a number from 

0 to 255. A higher value for a particular channel means that more of the colour is being used 

(more light coming through the screen). For example if a picture has a colour value of (232, 135, 

92) then that image has a lot of red, a medium amount of green and a lesser amount of blue. 

Below are some examples of some RGB colour values. 

 

 255,255,255 Maximum amount of all three colours creates white. 

 0,0,0 No colours creates black (since thereôs no light of any colour). 

 255,0,0 Maximum red with no green or blue makes red. 

 255,255,0 Maximum red and green with no blue makes yellow. 

 255,125,255 Maximum red and blue with medium green makes a light pink. 

 100,100,100 Equal amounts of all three channels makes a shade of grey. The 

higher the numbers, the lighter the colour (as more light is being 

used to create the image) 
 

CMYK Mode 

CMYK (Cyan Magenta Yellow Black) mode is the preferred mode for work that will be printed. 

That is because professional printers generally print with a mix of cyan, magenta, yellow and 

black ink. In Photoshop, a CMYK image has four channels. Each channel represents one of the 

colours by a percentage value. I.e. a higher value for a particular channel means that more of 

that colour is being used. If you imagine the image being printed, then more ink creates a darker 

image. Similarly, higher values in each channel leads to darker colours. In the example below, 

the Cyan channel shows the areas of the image where cyan ink would be used in printing the 

image. Darker areas show that more cyan ink would be used in those areas of the image during 

printing. 

 

 
Cyan channel 

 
Magenta channel 

 
Yellow channel 

 
Black channel 

 
Combined channels 
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Below are some examples of CMYK colour values. 

 

 0%,0%,0%,0% No ink colours leaves white. 

 100%,100%,100%,100% Maximum of all ink colours creates black. 

 0%,100%,100%,0% Maximum magenta and yellow only creates red. 

 0%,0%,100%,0% Maximum yellow only makes yellow. 

 24%,68%,0%,0% Some cyan and magenta makes a light pink. 

 67%,54%,41%,15% A mix of all channels can make grey. 

 

Greyscale Mode 

What we often think of as a black and white image is not really black and white. Rather it is 

made up of many shades of grey ranging from white through to black. A greyscale image has 

only one channel. This channel has 256 values from 0 (black) to 255 (white). Photoshop can 

also be set to show greyscale value as a percentage, where 0% is white and 100% is black. 

 

Bitmap Mode 

Bitmap mode images use only white or black pixels with no shades of grey used. The same 

picture used as a greyscale image above is shown below in bitmap mode. 

 

 
Tip In the Channels Palette, you can view each channel in an image by clicking on it. You can also 

select a channel by using its keyboard shortcuts which are shown next to each channel name. 
(colour = [Ctrl] [2], Channel 1 = [Ctrl] [3] etc). 
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Exercise 1 ï  Converting Image Modes 

1) Open the 1-rose.jpg image in Photoshop. 

The title bar across the top of the image will tell you that this is an RGB image. JPEG files can 

only be saved as RBG or Greyscale images. 

 
 

Now a bit of maths for you! 

The number 8 after RGB indicates that the image has 8 bits per channel. 

8 bits = 2
8
 = 256 colours per channel 

3 channels make a 24 bit image since 2
24

 is approximately 16.7 million colours (or 256×256×256). 

2) From the Image menu select Mode and then select CMYK Color. 

You may notice a slight change in the colour of the image 

as the colour mode is changed. This mode is more 

suitable for accurate reproduction of work that will be 

printed professionally. 

3) From the Image menu select Mode. You will notice that the Bitmap and Duotone modes are 

not available as you canôt convert a colour image to either of these modes. Select Grayscale 

from the Mode menu. You may get a message confirming that you will lose colour. 

When you convert an image to greyscale mode, the colour information is lost. Changing the 

image mode back to RGB or CMYK makes it possible to add colour but wonôt restore the old 

colours. The only way to restore the colour is to use the undo command or History Palette to 

reverse the mode change. 

 

4) From the Image menu select Mode. You will notice that 

all of the image modes are now available. Select Bitmap 

from the modes. A dialog like the one to the right will 

appear. 

5) Leave the Resolution options as they are and click OK. 

You will now have a 2 bit image. In other words, the 

image only has 2 colours (2
2
) which are 

black and white. There are no grey or 

coloured pixels. The effect is most 

obvious at 100% magnification as 

shown to the right. 
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6) Use the undo command [Ctrl] [Z] to return the image to Greyscale mode. 

Some image modes arenôt available for a new image but are available for converting an existing 

image. 

7) From the Image menu select Mode and then select Duotone. A dialog box like the one below 

will appear. 

 

A duotone image is like a greyscale image that is printed using a colour ink instead of a black 

ink. More than one ink colour can be used to create the effect of a tinted black and white image. 

8) Click on the coloured box as shown above. The Colour Picker (explained in detail later) will 

appear. 

 
9) Drag the vertical hue slider down to yellow and drag the circle to a darker area as shown. 

10) Click OK to close the Colour Picker and click OK again to close the Duotone options (You 

may need to enter a colour name). Instant sepia tone for that old fashioned look! 

 
11) Close the picture without saving any changes. 

Drag the 
vertical 

slider to here 

Drag the 

circle to here 
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2 -  Selecting Colours 

Photoshop provides several ways for selecting colours. Some of these methods you will have 

already seen in previous sections. These methods include the Colour Picker, the Swatches 

Palette, the Colour Palette and the Eyedropper Tool. Some methods of selecting colour may be 

slightly different depending on which colour mode your image is in. In Photoshop, you can have 

two colours selected at any given time. A foreground colour and a background colour. Both are 

used in different ways and both will be used in the exercises which follow. 

Exercise 2 ï  Using the Colour Picker 

1) Create a new image with the options shown below 

 

Weôll practice selecting colours by making use of fills and gradients. 

Look at the bottom of the tool palette and you will see the colour picker icons. 

 

2) Click the Foreground Colour Selector to display the Colour Picker. 

 
The colour picker may look complicated but itôs a lot easier to use than it looks. The numbers on 

the right hand side allow you to set a colour by typing in values directly. For example if you 

knew that the colour you wanted had an RGB value of 125, 130, 20, you could enter the value 

directly. The other amounts allow you to set the colour using different modes such as HSB (hue, 

saturation, brightness), LAB colour and CMYK colour. 

3) Try entering R-170, G-100 and B-20 as shown on the following page. 

Swap foreground & background colours [X] 

Select background colour 
Select foreground colour 

Set to default colours [D] 
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You should currently have a dark orange colour selected. Near the top of the dialog is a box 

which shows the colour you started with in the bottom half and the colour you have selected 

in the top half. The top half will change to show you any colour changes you make. You can 

click the bottom half at any time to return to the original colour.  

In most case you will use the colour picker to select colours visually. First of all, you use the 

vertical hue slider to pick the colour hue you are after. 

4) Drag the hue slider until you have a green colour selected as shown to the right. 

The large square area allows you to adjust the shade of the selected hue. A circle indicates the 

shade currently selected. 

¶ Dragging the hue closer to the bottom selects a darker shade. 

¶ Dragging it all the way to the bottom edge selects black. 

¶ Dragging it closer to the top left corner selects a lighter colour. 

¶ Dragging all the way to the top left corner selects white. 

¶ Positioning the circle anywhere along the left edge will select a shade of grey (lighter grey 

near the top and darker grey near the bottom. 

¶ Dragging to the top right corner selects brighter shades of the selected hue. 

5) Practice dragging around the square. Notice the numbers on the right changing to show the 

selected colour values. 

6) Try dragging all the way to each corner. 

7) Try to select a dark green colour similar to the one shown below. 

 

8) Click OK to apply the colour change. 
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The selected colour will now appear in the Toolbox as the Foreground Colour. 

 

9) Select the brush tool by clicking the icon  or by pressing the [B] key. 

10) Try painting with the selected colour. 

11) Click the Background Colour square to open the colour picker again, this time to change the 

background colour. 

12) Click the Color Libraries button (below the OK and Cancel buttons). This changes the Colour 

Picker to the Colour Libraries picker. 

 

The Book list at the top allows you to select from several common colour óbooksô. For example, 

may professional printers use the Pantone colour book ( www.pantone.com ) to use numbers for 

identifying particular colours. An organisation might have a logo that needs to be a specific 

colour throughout the organisation. Specifying a pantone colour ensures that whenever the 

organisation asks a professional printer to print the logo it will always be the same colour. 

13) Scroll through the list to view the colours available. 

14) Type the number 386 to select the colour PANTONE 386 which should be a pale yellow 

colour. 

15) Click OK to set the background colour. Both of your selected colours will display in the 

toolbox. 

 

 
Tip At the bottom of the colour picker, the currently selected colour is represented as a hexadecimal 

code. These codes are frequently used to represent colours in HTML so website developers can 
select a colour, copy the hexadecimal code and then paste it in to their HTML. 

 

Hexadecimal code 

http://www.pantone.com/
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Exercise 3 ï  Using Foreground and Background Colours 

1) From the Edit menu select Fill. 

 

2) Make sure the Use option is set to Foreground Color and click OK. 

The image will now be filled with the foreground colour. You can also use the Fill option to fill 

your image with the background colour. Additionally, some shortcuts can be used. 

3) Press [Ctrl] [Delete] to fill the image with the background colour. 

4) Press [Alt] [Delete] to fill the image with the foreground colour. 

 
Tip You can use selections (covered in the next section) to restrict what parts of the image are filled 

with the selected colours. 

 

The toolbox has a Fill tool  which works in a similar way to the menu option. The Fill tool is 

also grouped with a Gradient tool. 

5) Hold your mouse button on the Fill tool to show the 

Gradient tool and then select the Gradient tool. You can 

also use the [Shift] [G] tool to select the Gradient tool. 

6) The Options Palette along the top will show gradient options. The first of these allows you to 

choose from several gradient presets. Make sure the first one (foreground to background) is 

selected. 

 

7) Next on the Options Palette is a selection of gradient types.  Make sure 

the first one is selected. 

8) Drag across the image to create a gradient fill. The point you start dragging from will have 

the foreground colour. The point you finish dragging at will have the background colour. 

The areas in between with have an even colour blend. 
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  Ą   

9) Try using some of the other gradient styles.  

 

 
Linear gradient 

 
Radial Gradient 

 
Angle Gradient 

 
Reflected 
Gradient 

 
Diamond 
Gradient 

 

10) Click the Switch Foreground and Background Colours icon near the colour picker 

icons or press the [X] key to swap the foreground and background colours. 

 

11) Click the Default Foreground and Background Colours icon or press the [D] key. 

This will change the foreground colour to black and the background colour to white. 

 

12) Save the image as Colours.psd and close the image. 

 
Tip If you are painting using the brush tool or another tool, you can keep two colours ready for use. 

Set one as the foreground and the other as the background. Then you can simply use the [X] 
key whenever you need to switch between them. 

 

Exercise 4 ï  Selecting Colours with the Eyedropper Tool 

1) Open the 1-Rose.psd image. 

2) Display the Info Palette (Select it from the Windows menu if needed). 

3) Move your mouse over the image. 

4) The info palette will display information about the pixels your 

mouse moves over. For any pixel your mouse moves over it 

will show the coordinates of the pixel (distance from the top 

and left of the image), the colour of the pixel in RGB and 

CMYK values and the dimensions of any selected area 

(explained in the next section). Notice that any lighter coloured 

pixels will have higher RGB values and lower CMYK values. 

5) Select the Eyedropper tool from the Tool Palette  or press the [I ] key. Your mouse pointer 

will change in to an eyedropper shape when over the image.  

6) Move your mouse over a dark red part of the image and click the mouse button. The 

foreground colour will be changed to match the colour of the pixel you clicked on. 

7) Move your mouse over a light green part of the image and click the mouse button 

while holding down the [Alt] key. The background colour will be changed to match 

the colour of the pixel you clicked on. 

 
Tip With the eyedropper tool selected you can drag slowly across the image and watch the colour 

icon in the tool palette until you have found a suitable colour to sample. 
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Exercise 5 ï  Using the Colour Palette 

Selecting colours using the Colour Palette is quite similar to using the colour picker, with a few 

small differences. 

1) Make sure the Colour Palette is showing. 

2) Click on the foreground colour box as shown below to make sure it is selected. The selected 

box will have a thicker border around it and indicates whether you are changing the 

foreground or background colour (Double clicking on either one will open the colour 

picker). 

 

There will be a horizontal slider for each channel in the image. In this case there is one each for 

red, green and blue. 

3) Try adjusting each slider until you end up with a dark purple colour. Hint: no green with a 

medium amount of both red and blue should give you the right colour. 

 

The Colour Bar along the bottom provides another way to select colours. If you move your 

mouse over it, the mouse pointer turns in to an eyedropper shape. This works in the same way as 

using the eyedropper tool on an image (So you can hold down [Alt] to select a background 

colour with it).  

 

4) Drag along the Colour Bar to view different hues. Drag closer to the top of the bar for lighter 

colours and closer to the bottom of the bar for darker colours. Try to select a light orange 

colour from the colour bar. 
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Exercise 6 ï  Adding to the Swatches Palette 

In a previous exercise you saw that the Swatches Palette displays a collection of colours that 

you may choose from when needed. This collection of colours can be customised, meaning that 

you can save colours for later use. It can also be replaced with one of Photoshopôs alternate 

swatches. 

1) Display the Swatches Palette. 

2) Make your foreground colour a light orange colour such as the one shown.  

3) Move your mouse over a blank area on the swatches palette. Your mouse pointer will turn in 

to a bucket shape. 

 

4) Click to create a new colour. A dialog asking you to name the colour will appear. 

 

5) Enter Light Orange for the colour name and click OK. Move your mouse over the new 

colour and its name will appear. 

Collections of colours can be saved in case you need to reinstall Photoshop or use them 

on a different computer. All Photoshop palettes have a menu that can be displayed by 

clicking the small triangle in the top right corner of the palette.  

6) Display the palette menu as shown and select Save Swatches. 

 

7) Select an appropriate location for your custom swatch and name it Custom.aco. You can 

save over it again if you add additional colours. 

Note You can delete a colour from a swatch by dragging it on to the bin icon  at the bottom of the 
palette. You can also create a new swatch/colour by clicking the  icon at the bottom of the 
palette. 
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3 -  Additional Colour Tips 

Colour Gamut 

A Gamut refers to a range of colours that is available in a certain situation. Not all devices are 

capable of displaying the same colours. For example, your computerôs monitor might be capable 

of displaying a bright green colour which might not be possible to duplicate with ink from a 

printer. Photoshop can indicate out of gamut colours in a couple of ways. 

Firstly, if you are using the Colour Palette or the Colour Picker, a ó!ô symbol may appear next to 

your selected colour if it is out of gamut. This often happens when you have selected a very 

bright colour which would not look the same if it were printed. When the ó!ô appears, it will 

appear near a small colour square which indicates a suggested colour that is not out of gamut. 

Clicking this small square will set that as the selected colour. 

Another way that out of Gamut colours may be indicated is in your Info Palette. When you move 

your mouse over a pixel that has an out of Gamut colour, the CMYK values will be followed by 

exclamation signs instead of percentage signs. 

 
Normal colour 

 
Out of Gamut colour 

Web Safe Colours 

Different platforms display many colours differently. For instance, a computer user viewing a 

web page on an Apple Mac with Firefox as the browser might see different colours to another 

user viewing a web page on a Windows PC with Internet Explorer as the browser. There is a 

standard set of 216 colours that will look the same regardless of the platform used. This set of 

colours is known as Web Safe colours, since many website designers make a point of choosing 

colours from within this range. 

When you are selecting colours using the Colour Palette or the Colour Picker, a  symbol will 

appear if you have selected a colour that is not óweb safeô. You can click the small coloured 

square under the symbol to change to the closest available web safe colour. 

 

Tip Photoshop includes a web safe colours collection called Web Safe Colors.aco that can be 
loaded in the swatches palette. If you want to load the web safe colours, you can select them 
from the swatches menu. 

 

Out of gamut colour selected 
Click to replace with a colour 

that is not out of gamut 
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4 -  Saving Files 

When you are ready to save a file in a format other than PSD, you need to be aware of some of 

the different features of different file formats.
1
 For instance, you wonôt be able to save an image 

in GIF format unless it is in indexed colour mode. The Indexed Colour mode means that the 

picture is made from a selection of no more than 256 colours. With some file types, you may be 

prompted for additional information about the file. The following examples show some of the 

options that may appear when you choose to save a file in a certain format. 

 
 

Bitmap saving options 

 
 

JPEG saving options 

 
 

TIFF saving options 

Even though you may be able to select additional options when you save a file, those options 

might not be used by all programs. For example JPEG images have a feature called progressive 

rendering. This means that if the image is loading in a web page, instead of gradually appearing 

from top to bottom, the whole image will appear and get clearer as it continues to load. Internet 

Explorer is capable of displaying JPEG images, but older versions will not make use of the 

progressive rendering feature as other web browsers might. Likewise, if you save a TIFF image, 

you have the option to retain transparent areas and layers, though some older programs such as 

Adobe PageMaker will only recognise TIFF images that donôt have these extra features. 

                                                 
1
 For an overview of file formats see http://www.oneil.com.au/pc/general/CommonRasterImageFormats.pdf  

http://www.oneil.com.au/pc/general/CommonRasterImageFormats.pdf
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Exercise 7 ï  Saving a TIFF Image 

1) Make sure you have the 1-rose.jpg open in Photoshop. 

For an image that will be printed, it is best to convert it to CMYK mode. This will ensure that any 

out of gamut colours are converted to colours that will print well. 

2) From the Image menu select Mode and then CMYK Color. 

3) From the File menu select Save As or press [Ctrl] [Shift] [S]. 

 

4) Change the list of file types to TIFF. 

5) Click Save. The TIFF options dialog will appear. Click OK to complete the save. 
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Exercise 8 ï  Save for Web Options 

For websites the common file formats are GIF, JPEG and PNG. These can be saved like other 

files, but to take advantage of the features in each of these image formats you can use the Save 

for Web feature. 

1) Open the 1-rose.jpg open in Photoshop. 

2) From the File menu select Save for Web or press [Ctrl] [Alt] [Shift] [S] (A long shortcut but 

well worth remembering if you do a lot of work on websites). A dialog like the one below 

will appear.  

 

3) The main area is taken up with a preview of your image. Click the 2-up tab along the top. 

This will split the preview screen in two halves. The first will show your image normally. 

The second will show how your image will look with the save options you have selected. 

You can zoom on the preview and move around the preview just as you would normally in 

Photoshop. 
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Under the second preview, you will see some information about the image. This will show the 

currently selected file type along with other information such as an estimate of the final file size 

and the estimated download time one a specified internet connection speed. 

 

4) From the options on the right, set the file type to JPEG. The rest of the options will change 

to suit the JPEG format. 

 

5) Try changing the quality settings. If you set it to high amounts, the two preview images 

wonôt look much different but the estimated file size will be relatively high. Change to a 

lower quality setting and the estimated file size will be small, but you will notice a 

difference in the quality of the preview image. 

 

E.g. 

 
 

Good quality but large file size 

 
 

Small file size but poor quality 

6) Set the quality to the lowest amount you can without too much loss of image quality (around 

40% should be ok). 

7) Click Save to complete the options. 

8) Select an appropriate file location. Enter rose web as the file name and then click Save. 

 

Note Photoshop will replace the space in the filename with a dash since it is best to avoid spaces in 
filenames. Many web developers use a dash ï or an underscore _ instead of spaces. 
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9) Close the rose image. You may be prompted to save again but there is no need since you just 

exported it with the web options. 

10) Open your Lines.psd image. If you didnôt save it earlier then create an image to look like the 

one below. 

 

Since this image has very few colours and has large areas of solid colour it is ideal for the GIF 

file format. 

1) From the File menu select Save for Web or press [Ctrl] [Alt] [Shift] [S]. 

2) Set the file type to GIF. 

 

The colour table shows the number of colours currently used in the image. It includes a lot of 

different shades of grey that are used to make the edges of the lines appear smoother. In many 

cases, the image can still look good with a lot less colours, which results in a smaller file that 

will download quicker in a web site. 


