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Using Microsoft Excel 
Working with Sheets  
Files in Microsoft Excel are referred to as Workbooks. This is because 
they can contain more than one sheet. The number of sheets a 
workbook can contain is only limited by your computer’s memory. 
Having several sheets in a workbook makes it possible to have 
several similar tables with different data. For example a business 
wanting to keep track of sales data could have a sheet for each 
month of the year and then create a thirteenth sheet that adds up the 
totals from each month. Having the tables on separate sheets is a lot 
neater and easier to work with than having several tables all cluttering up 
the same sheet. 
The exercises below will look at the use of features such as Grouping Sheets, Linking Sheets 
and Sheet Protection. Here is a brief description of these skills. 
 
Grouping Sheets Grouping sheets allows you to edit several similar sheets at once. 

Linking Sheets Create formulas that connect data from two or more sheets. 

Sheet Protection Restrict your worksheet so that only certain parts may be modified. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Excellent! 
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Exercise 1. Creating Extra Sheets 
1) Make sure Excel is open with a blank workbook. By default a new 

workbook will contain 3 sheets. 
2) The first sheet in the workbook should be selected.  
3) From the Insert menu select Worksheet. A new worksheet (probably titled 

Sheet4) will be added to the workbook. 
4) Right click on any sheet tab and select Insert. An Insert Dialog will appear. 
 

      
 
5) Make sure Worksheet is selected and click OK. A new worksheet will be added. 
6) Use either of the above methods to create a 6th worksheet. 

Exercise 2. Renaming Sheets 
1) Make sure the first sheet is selected (it doesn’t matter what 

number is on it). 
2) From the Format menu select Sheet and then Rename. 

The name of the sheet will be highlighted so it can be changed.  

 
 

3) Type Jackson for the name of the sheet and then press [Enter] or click away from the tab. 

You can also right-click on a sheet tab and then select Rename from the shortcut menu but the 
quickest way is to double-click on the sheet tab. 

4) Double-click on the second sheet tab and enter Hawkins as the name. 

5) Rename the rest of the sheets so they appear as shown below. 

 
 

 
Tip If you want to change the number of sheets that are created with a new workbook, select Tools, 

Options and then select the General tab. You can then set the number of sheets a new 
workbook will have. 
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Exercise 3. Navigating Sheets 
In the current workbook, there is only a small number of sheet tabs. On a 
workbook with more sheets, the tabs may not all fit in the bottom area of the 
screen. When that is the case, you can use the sheet navigation buttons to view the 
tabs that won’t fit. These are located to the left of the sheet tabs and are shown below. 

 
 

 Moves the sheet tabs all the way to the left until the first one is visible. 
 Moves the sheet tabs to the left one at a time. 
 Moves the sheet tabs to the right one at a time. 
 Moves the sheet tabs all the way to the right until the last one is visible. 

 

You can also navigate through worksheets in other ways. 

1) Right-click on the sheet navigation buttons to the left of the sheet tabs. A list of 
sheet names will appear. Click on one of the sheet names to move to that sheet. 
When there are too many sheet tabs to fit along the bottom, this can be a quick 
way to select sheets. 

If the workbook has too many sheets to list, there may be a More Sheets option at 
the bottom of the list. 

2) Click on the Hawkins sheet tab to select that sheet and view its contents (currently an empty 
worksheet). 

3) Hold down the [Ctrl] key and press [Page Down] to move down one sheet at a time. 
4) Hold down the [Ctrl] key and press [Page Up] to move up one sheet at a time. 

Exercise 4. Grouping Sheets 
In our current workbook, we will be creating several sheets that will contain statistics about 
basketball players. Each sheet will have the same headings, formatting and formulas so we can 
save time by editing them all at once. This is done by grouping the sheets. 

1) Click on the first sheet tab to select it. 
2) Hold down the [Shift] key and click on the fourth sheet to 

select it. All of the sheets in between will become selected. 

 

henever more than one sheet is selected, the word [Group] will 

) Hold down [Ctrl] and click on the last sheet to select it. 
d sheets to deselect it. 

 

6) d choose S

W
appear next to the filename in the title bar to indicate that you are
can also use the 

 working in group mode. You 
[Ctrl] key to select or deselect sheets. 

 

3
4) Hold down [Ctrl] and click on one of the already selecte
5) Click on an unselected sheet without holding down any key to select that sheet

alone and deselect all others. 
Right click on any sheet tab an elect All Sheets to group all sheets. 

7) Right click on any sheet tab and choose Ungroup Sheets so that only one sheet is 
selected.  
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Exercise 5. Moving and Copying Sheets 
You can copy existing sheets or change their order in a couple of ways. 

1) Right click on a sheet tab or select the Edit menu and then select Move or Copy. A dialog like 
the one below will appear. 

 
 

This allows you to move sheets within the current workbook or to another workbook. You can 
tick the option at the bottom to copy instead of moving. In most cases it is quicker and easier to 
copy and move sheets using your mouse. 

2) Cancel the Move sheets dialog. 
3) Move your mouse over the Adams sheet tab. Drag it between 

the Hawkins and Lyall tabs to move it to that position. 
4) Move your mouse over the Averages tab. Hold down the [Ctrl] key and drag to the 

right. A + sign will appear next to your mouse pointer indicating that you are making 
a copy instead of moving the sheet. Release you mouse button to create a copy of the sheet 
in that position. 

 

 
 

We don’t actually need an extra sheet at the moment so we’ll get rid of it. 

5) Right click on the extra sheet tab and select Delete. You can also select the Delete Sheet 
option from the Edit menu. 

 

 
 
6) You will be prompted to confirm the operation. Click on the Delete button. 
 
Note Deleting a sheet cannot be undone. 
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Exercise 6. Editing Grouped Sheets 
1) Group all of the sheets in the workbook except for the Averages sheet, using any of the 

methods you have learned. 

All of the selected sheet tabs should be highlighted. While the sheets are grouped, it doesn’t 
matter which of the grouped sheets we are editing as the changes will be made to all of the 
sheets at the same time. 

 
 

2) Create a table similar to the one below with formatting of your choice. 

 
 

3) Ungroup the sheets when you are done. 
4) Click on any of the sheet tabs. You will see that the table will be on all except the averages 

sheet. 
5) Save the workbook as Panthers Basketball Club. 
6) Add data to the tables on each of the sheets so that they are like the ones shown below. 
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Exercise 7. Linking Sheets 
When you have more than one sheet, it is possible to create a formula that will link several 
sheets together. With our workbook we will create a table that displays averages based on 
information in the other 5 sheets. We could do exactly the same thing using any other 
calculations such as sum or count. 

1) Create a table like the one below on the Averages sheet (Hint – you can copy most of it from 
one of your other sheets and modify as needed). 

 

 
 

2) Click in the cell for player height (cell B3). 
3) Begin creating an average function by entering =AVERAGE( 

Remember that you can use the AutoSum icon on the toolbar to create average 
functions as well if you don’t feel like typing it. 

You can use the mouse to select other cells in other sheets for your formula to refer 
to the same as you would for cells on the same sheet. 

4) Click on the Jackson sheet tab. The formula will add the sheet name followed by an 
exclamation mark to indicate a sheet reference. ( =AVERAGE(Jackson! ). 

5) Click the Height cell for Jackson. The formula should now show =AVERAGE(Jackson!B5 
6) Type a comma to indicate that we will be adding an extra cell to our average function. 
7) Click the Hawkins sheet tab and then select the height cell for Hawkins. 
8) Add the height cells for each of the other sheets until the formula looks like the one below 

and press [Enter] to complete the formula. 

=AVERAGE(Jackson!B5, Hawkins!B5, Adams!B5 ,Lyall!B5, Brown!B5) 

The average of all of those cells will now be displayed. Although each of the cells referred to are 
on separate sheets, we can still take advantage of relative referencing to copy the formula so that 
it creates averages for the rest of the statistics. 

9) With the average cell selected, move your mouse over the fill handle. Double 
click on the fill handle to copy the formula down to the end of the table. 

Relative references will ensure that each cell’s averages refer 
to the cells below the previous one. Copying the function down 
will most likely copy the formats as well. If this results in your 
border formatting being changed, you can use the smart tag in 
the last cell to make sure that cell contents are copied without 
the formatting.  
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Exercise 8. Using the Consolidate Tool 
If you want to create a sheet which summarises information from several similar sheets, a quick 
way to do it is to use the Consolidate tool. The method we have already used for linking cells is 
suitable when only a few linked cell references are needed. When a large range of cells in 
different sheets need to be added, averaged, counted etc it can be easier to use the method shown 
below. We will create another sheet that averages the player’s statistics using the Consolidate 
tool. 

1) Create a new sheet in your workbook and call it Consolidation.  

2) Create headings on this sheet as shown below. 
 

 
 
3) Select cell A3. 
4) From the Data menu select Consolidate. The following dialog will appear. 
 

 
 
5) Change the Function from Sum to Average. 
6) Click in the Reference box. Now it’s time to select which cells on each sheet will be 

consolidated. 
7) Click on the Jackson sheet tab. The Consolidate dialog will still remain visible allowing you 

to select the cells you need. 
8) Select cells A3 to B15 on the Jackson sheet. These cells should contain all of the player’s 

stats along with the labels. The reference box should show Jackson!$A$3:$B$15. 
9) Click Add to add the cell range to the All references list. 
10) Click on the Hawkins sheet tab. The sheet name in the Reference box will change to 

Hawkins so that the reference appears as Hawkins!$A$3:$B$15. Click the Add button to add 
the reference. 

11) Do the same to add the statistics for the other 3 players’ sheets. 
12) Click the check box for Use labels in Left column to select it. This will ensure that they 

information in the first column will be recognised as labels rather than as part of the data. 
13) Click the check box next to Create links to source data to select it. This will ensure that 

functions are used to create the averages so that they will update when the source data 
changes. 
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14) Check to ensure that the options look like the example below. 
 

 
 
15) When you are happy with the selections click OK. 

Click in any of the average cells and you will see regular average functions have been created. 
One difference with using this method is that an outline is created. This can be expanded to 
show the individual data from each sheet. If you click on one of these expanded cells, such as 
C7, you will see a formula that links to the original data, such as =Hawkins!$B$5. 

 
16) Click in some of the different cells to view the formulas that have been created by the 

Consolidation tool. 
17) Save the changes to the file. 
 
Note You can also link to other Excel workbooks. The example below shows how a formula linking to 

another workbook might appear. 
 

=[Functions.xls]Functions!$C$9 
 
 

File name. If the file is not saved in 
the same folder the full path may be 
needed. E.g. [C:\Files\Functions.xls] 

Sheet name Cell reference 
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Exercise 9. Worksheet Protection 
A worksheet can be protected so that only certain cells can be edited. Protecting a workbook 
involves a couple of steps. By default, all cells in a sheet are locked but sheets protection is not 
turned on. First of all you need to specify which cells will be unlocked (available for editing). 
Then you can enable sheet protection. Additionally, you can select the hidden option for cells so 
that any formula used to create the data in that cell will not be visible. 

1) Group all 5 of the player sheets. 
 

 
 
2) Select all of the cells that you want users of the sheet to be able to edit. The following 

example shows B3:B15 selected. 
 

 
 
3) Display the Format, Cells option from the menu or by using the [Ctrl] [1] shortcut. 
4) Click on the Protection tab. 
5) Click the Locked checkbox to clear it so that these cells will be unlocked. 
 

 
 
6) Click OK. When sheet protection is enabled, only these cells can be edited. 

Before you can enable sheet protection you will need to ungroup the sheets, since you can only 
protect one sheet at a time. 

7) Ungroup the sheets and make sure one of the player sheets is still selected. 
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8) From the Tools menu select Protection and then select Protect Sheet. 

 
 

The Protect Sheet options allow you to enter a password. If you provide a password here, then 
the sheet can’t be unprotected without using that same password. You can leave it blank if you 
want to allow protection to be turned off without a password. The other options provide control 
over what can and can’t be modified when the sheet is protected. 

 

 
 
9) Enter a password if you want to use one and then click OK to turn on the sheet protection. 
10) Try to change one of the cells you unlocked. You’ll be able to change it as normal. 
11) Try to change one of the other cells and a message like the one below will appear. 
 

 
 
12) Click OK to close the message. 
13) Protect the other player sheets and save the file. 
 
Note Worksheet passwords can be up to 255 characters and they are case sensitive. Don’t forget 

your password if you use one. 
 
Tip In addition to protecting sheets, you may have also noticed a protect workbook option. Protecting 

a workbook can prevent users from doing things like moving, creating, copying, renaming or 
hiding worksheets. 
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